Some customers unable to login to Pipedrive
Incident Report for Pipedrive
Resolved
The issue has been fixed and our systems are back to normal. Sorry for the inconvenience.
Posted over 1 year ago. Jul 06, 2016 - 14:13 EEST
Investigating
Some customers can't login to Pipedrive at the moment. We are investigating the reasons behind the issue.
Posted over 1 year ago. Jul 06, 2016 - 12:26 EEST