Google drive
Incident Report for Pipedrive
Resolved
The problem with Google drive is resolved.
Posted about 1 month ago. Sep 08, 2017 - 19:52 EEST
Investigating
Some users are not able to upload files using Google drive. We are working on it.
Posted about 1 month ago. Sep 08, 2017 - 12:09 EEST