Issues with the search functionality
Incident Report for Pipedrive
Resolved
Search is back to normal! Sorry for the inconvenience.
Posted about 1 year ago. Dec 01, 2016 - 13:34 EET
Investigating
Some of our customers may experience issues with the search functionality. Very sorry! Our tech team is on it, will post an update soon.
Posted about 1 year ago. Dec 01, 2016 - 12:46 EET