Smart BCC slowdown
Incident Report for Pipedrive
Resolved
Smart BCC is back to normal! Sorry for the inconvenience.
Posted over 1 year ago. Aug 31, 2016 - 18:42 EEST
Investigating
Due to an open issue with our Smart BCC service provider, incoming Smart BCC emails are experiencing delays. We're on it.
Posted over 1 year ago. Aug 31, 2016 - 18:18 EEST