Some users are facing issues while login the Webapp
Incident Report for Pipedrive
Resolved
All users are able to login to Pipedrive Webapp properly again.
Posted about 1 month ago. Jan 16, 2018 - 14:44 EET
Investigating
Some users are facing issues while login the Web-app. The issue is under investigation.
Posted about 1 month ago. Jan 15, 2018 - 17:15 EET