Email Spam
Incident Report for Pipedrive
Resolved
Emails have stopped and no more spamming. Many apologies for the incident 🙂
Posted 24 days ago. May 01, 2018 - 19:47 EEST
Identified
Problem found and deploying a fix.
Posted 25 days ago. May 01, 2018 - 19:29 EEST
Investigating
A spam issue with emails targeting our affiliates regarding monthly reports
Posted 25 days ago. May 01, 2018 - 19:07 EEST