Service not available
Incident Report for Pipedrive
Resolved
...and we're back. Sorry for the disruption, Sunday sales warriors!
Posted 7 months ago. Jun 04, 2017 - 12:27 EEST
Identified
The cause was a networking issue with our hosting partner, they and we are on it.
Posted 7 months ago. Jun 04, 2017 - 12:15 EEST
Investigating
Pipedrive is currently not available. We're investigating and will give an update shortly. We're very sorry for the disruption!
Posted 7 months ago. Jun 04, 2017 - 12:09 EEST