Some users are facing service outage
Incident Report for Pipedrive
Resolved
This incident has been resolved.
Posted 4 months ago. Aug 04, 2017 - 10:04 EEST
Investigating
We have an incident that is causing an outage for some customers using Pipedrive.
We are investigating it, probably is gonna be back in 30 minutes.
Posted 4 months ago. Aug 04, 2017 - 09:59 EEST