Data import unavailable
Incident Report for Pipedrive
Resolved
.. and we're back. Apologies!
Posted 10 months ago. Mar 02, 2017 - 13:34 EET
Investigating
Data import is unavailable for many users, our tech team is investigating. Sorry for the trouble!
Posted 10 months ago. Mar 02, 2017 - 11:55 EET