Slack functionality
Incident Report for Pipedrive
Resolved
Issue Resolved.
Posted about 1 month ago. Mar 14, 2018 - 11:38 EET
Identified
We are investigating degraded slack performance.
Posted about 1 month ago. Mar 14, 2018 - 11:14 EET