Some customers unable to login to Pipedrive
Incident Report for Pipedrive
Resolved
The issue has been fixed and our systems are back to normal. Sorry for the inconvenience.
Posted about 1 year ago. Sep 14, 2016 - 11:09 EEST
Investigating
Some customers in Europe can't login to Pipedrive at the moment. We are investigating the reasons behind the issue.
Posted about 1 year ago. Sep 14, 2016 - 10:54 EEST