Scheduling Issues
Incident Report for Pipedrive
Resolved
Scheduler is working amazingly again.
Posted about 1 month ago. Jan 23, 2018 - 13:31 EET
Identified
We are aware and actively working on it.
Posted about 1 month ago. Jan 23, 2018 - 12:25 EET