Some users are facing service outage
Incident Report for Pipedrive
Resolved
Maintenance is finished and everything is back to normal now.
Posted 4 months ago. Aug 25, 2017 - 14:32 EEST
Identified
Some of our servers are on maintenance due malfunction, shortly everything will be back to normal.
Posted 4 months ago. Aug 25, 2017 - 13:54 EEST