Issue with filter
Incident Report for Pipedrive
Resolved
Incident has been resolved!
Posted 7 months ago. May 22, 2017 - 18:59 EEST
Investigating
Filter conditions are not being applied after you save it. We are investigating the cause of it. Very sorry! We will post na update soon.
Posted 7 months ago. May 22, 2017 - 18:28 EEST