DB Issues
Incident Report for Pipedrive
Resolved
Resolved.
Posted 3 months ago. Dec 04, 2017 - 13:39 EET
Identified
We have identified some issues on a few DB's. We are working on them.
Posted 3 months ago. Dec 04, 2017 - 12:12 EET