Some users are not able to add new deals from list view
Incident Report for Pipedrive
Resolved
Issue is resolved.
Posted 3 months ago. Nov 22, 2017 - 20:03 EET
Investigating
Issue affect only the users who use non-english version of pipedrive.
As a quick workaround you can change application language to English until issue is resolved.
To change the language or local in Pipedrive, go to Settings > Personal > Profile.
Posted 3 months ago. Nov 22, 2017 - 19:23 EET