Email Tracking
Incident Report for Pipedrive
Resolved
Email Tracking issue solved. Events are coming in real time.
Posted 3 months ago. Jan 25, 2018 - 21:12 EET
Investigating
There are some issues determining Email Tracking results; currently investigating.
Posted 3 months ago. Jan 25, 2018 - 19:28 EET