Issue with new U.S. signups
Incident Report for Pipedrive
Resolved
U.S. signup has resumed to normal
Posted 3 months ago. Jan 17, 2018 - 22:50 EET
Investigating
New users cannot sign up in the U.S. We are aware and working on it 8^)
Posted 3 months ago. Jan 17, 2018 - 22:43 EET