In-App Support Down
Incident Report for Pipedrive
Resolved
Feel free to contact us!
Posted 3 months ago. Feb 21, 2018 - 22:45 EET
Investigating
Our in-app support system, Intercom, is down and our Support Team is anxiously waiting to resolve any issues you may be experiencing. Continue to monitor this page for updates OR watch Intercom's status page - https://status.intercom.com/
Posted 3 months ago. Feb 21, 2018 - 22:19 EET