Degraded performance on some services
Incident Report for Pipedrive
Resolved
Everything should be back to normal. We apologise for the inconvenience If you’re still experiencing issues please get in touch with our support team.
Posted 10 days ago. May 16, 2018 - 12:06 EEST
Investigating
We're currently investigating issue reports regarding different services malfunctioning for some companies in EU. We’ll be in touch with more information soon.
Posted 10 days ago. May 16, 2018 - 11:39 EEST
This incident affected: Web app.