Data Import is not functioning properly
Incident Report for Pipedrive
Resolved
Our dev team fixed the issue.
Posted over 1 year ago. May 25, 2016 - 13:47 EEST
Investigating
Our dev team is looking into the issue.
Posted over 1 year ago. May 25, 2016 - 12:58 EEST