Partial DB Outage
Incident Report for Pipedrive
Resolved
This incident has been resolved.
Posted 11 days ago. May 14, 2018 - 19:29 EEST
Identified
Issue has been identified and a fix will be implemented soon.
Posted 12 days ago. May 14, 2018 - 19:20 EEST
Investigating
We are currently investigating this issue.
Posted 12 days ago. May 14, 2018 - 19:00 EEST
This incident affected: Web app.