Some users experiencing difficulty logging in
Incident Report for Pipedrive
Resolved
Login issue fixed. Sorry for the inconvenience.
Posted about 1 year ago. Sep 21, 2016 - 19:57 EEST
Investigating
Some users are experiencing problems with logging in. We are investigating the reasons behind the issue.
Posted about 1 year ago. Sep 21, 2016 - 17:37 EEST