Full email sync slowdown
Incident Report for Pipedrive
Resolved
Full email sync is back to normal! Sorry for the inconvenience.
Posted 12 months ago. Oct 25, 2016 - 21:20 EEST
Identified
Some clients may experience delays. We're on it.
Posted 12 months ago. Oct 25, 2016 - 20:31 EEST