Data export service
Incident Report for Pipedrive
Resolved
Incident is resolved and all is fully recovered.
Everything should be back to normal. We apologise for the inconvenience
Posted 21 days ago. Apr 03, 2018 - 11:35 EEST
Investigating
We're currently investigating issue reports regarding data export service. We’ll be in touch with more information soon.
Posted 21 days ago. Apr 03, 2018 - 11:07 EEST