Submitting Webforms
Incident Report for Pipedrive
Resolved
Everything should be back to normal. If you’re still experiencing issues try clearing your cache and cookies. If that doesn’t work please get in touch with our support team.
Posted about 1 month ago. Mar 15, 2018 - 18:56 EET
Identified
We found the problem and are working on a solution. As soon as we fix it we’ll let you know and thank you for your patience.
Posted about 1 month ago. Mar 15, 2018 - 18:26 EET
Investigating
We're currently investigating issue reports regarding webforms.
We’ll be in touch with more information soon.
Posted about 1 month ago. Mar 15, 2018 - 17:58 EET