Webforms
Incident Report for Pipedrive
Resolved
Issues has been resolved
Posted 11 days ago. Apr 13, 2018 - 04:07 EEST
Identified
We're currently experiencing some issues with webforms. The issue has been identified but do not have an ETA of how soon a fix will be deployed.
Posted 11 days ago. Apr 13, 2018 - 00:37 EEST