Office365 and Trello integration login issues
Incident Report for Pipedrive
Resolved
This incident has been resolved.
Posted 4 months ago. Oct 27, 2017 - 10:20 EEST
Investigating
Users cannot currently log in to the add-in through outlook.
Trello Power Up is also affected. Sometimes login fails for some users
Posted 4 months ago. Oct 27, 2017 - 09:57 EEST