Import Mapping
Incident Report for Pipedrive
Resolved
This incident has been resolved.
Posted 2 months ago. Feb 13, 2018 - 14:44 EET
Investigating
We are currently investigating this issue.
Posted 2 months ago. Feb 13, 2018 - 01:57 EET