Issue with settings
Incident Report for Pipedrive
Resolved
This incident has been resolved.
Posted 9 months ago. Mar 14, 2017 - 12:09 EET
Identified
Some customers are experiencing problems with settings. We've identified the issue and deploying a fix.
Posted 9 months ago. Mar 14, 2017 - 11:53 EET