Language Issues
Incident Report for Pipedrive
Resolved
Resolved.
Posted 6 months ago. Oct 18, 2017 - 13:06 EEST
Identified
Users with their language set to Spanish and Portuguese are experiencing issues loading Pipedrive.
Posted 6 months ago. Oct 18, 2017 - 12:12 EEST